All systems operational

Please note: The uptime reported below is calculated on a 24/7 basis. However, our SLAs are based on business hours which could differ from the uptime shown.

Service outage

Resolved
Major outage
Started 2 months ago Lasted about 2 hours

Affected

Ajila Services
Forms Hub Service
Swisscom Sign Service
Updates
  • Resolved
    Resolved

    Summary of Impact: Between 07:57 CET on 22 February 2024 and 09:53 CET on 24 February 2024, as a customer you may have experienced issues when accessing our services.

    Preliminary Root Cause: We determined that a DNS configuration change caused some internal services to not being able to route correctly.

    Mitigation: We have restored the DNS configuration and are working on additional measures to prevent this type of issue to reoccur.

  • Identified
    Identified

    We have identified the root cause and are working to resolve the issue.

  • Investigating
    Investigating

    As a customer you may experience issues when using the Digital Deals or Blink Signing service.

    We are aware of the problems and are analyzing the issue.